Getting Flex Builder 3 plugin to survive a new Eclipse Version

Eclipse 3.5 (Galileo) has recently been released, so I'm in process of rebuilding my development environment to run on it.  I was happy enough to go use the update sites to re-install CFEclipse and MXUnit, and the StarTeam (our company's chosen Version Control software) plugin was able to seamlessly update the Galileo instance of Eclipse to include it's plugin, but I ran into a snag when trying to update the Flex Builder 3 plugin.

When originally installing the Flex Builder 3 plugin for eclipse, I used the default path (i.e. C:\Program Files\Adobe\Flex Builder 3 Plugin). When I tried to re-run the installer, It reported that I already had a Flex Builder Plugin instance at that location, and would I please choose another directory. Not wanting to clutter my hard drive with extra copies of the Flex Builder plugin, I decided to poke around and see what I could do to use the existing Flex Builder Plugin in my new Galileo installation.

What I eventually happened on was a very nice, clean way to install a single instance of an Eclipse plugin, and allow multiple copies of Eclipse use it.   It's pretty straight forward, and assumes you've already got a copy of Eclipse installed, and a licensed copy of the Flex Builder 3 Plugin installed.

First off, navigate into your eclipse directory.  Mine is C:\Program Files\Eclipse\Galileo\ .  This should be the folder which contains your eclipse.exe file.  Under this directory, if there isn't already a directory named "links", create one. Navigate into the links directory.  Create a new text file named "com.adobe.flexbuilder.feature.core.link".  Edit the file, and add the following contents to it:

path=C:/Program Files/Adobe/Flex Builder 3 Plug-in

Close the file, and start Eclipse.  Now go into your Window Menu, select "Open Perspective", and "Other", and you should see your Flex Development Perspective listed.  It's even smart enough to pick up the license key from your previous installation, so you don't have to dig out the old key to reinstall. However, for some reason, when I did this it lost my installed Flex SDKs.  To fix this, I went to the "Window->Preferences" dialog, and navigated to the "Flex->Installed SDKs" option.  I removed the two entries for "Flex 0.0" which were listed, and re-added the two existing Flex SDKs: c:\program files\adobe\flex builder 3 plug-in\sdks\3.2.0 and c:\program files\adobe\flex builder 3 plug-in\sdks\2.0.1   You must mark one of these as default by clicking the checkmark next to it on the screen.  After this, click Ok, and you should be good to go.

If you're doing ColdFusion development, don't forget to also install the ColdFusion extensions for Eclipse at C:\program files\Adobe\Flex Builder 3 Plug-in\Installers\ColdFusion Extensions for Flex Builder, and JSEclipse is also pretty helpful at C:\program files\Adobe\Flex Builder 3 Plug-in\Installers\JSEclipse